Can't install OpenMx on Mac OS X 10.7.2 (Lion) running R version 2.14.0

8 replies [Last post]
DavidCross's picture
Offline
Joined: 06/27/2011

R version 2.14.0 (2011-10-31)
Copyright (C) 2011 The R Foundation for Statistical Computing
ISBN 3-900051-07-0
Platform: x86_64-apple-darwin9.8.0/x86_64 (64-bit)

...

> source('http://openmx.psyc.virginia.edu/getOpenMx.R')
Warning: unable to access index for repository http://openmx.psyc.virginia.edu/packages/bin/macosx/leopard/contrib/2.14
Warning message:
In getDependencies(pkgs, dependencies, available, lib) :
package ‘OpenMx’ is not available (for R version 2.14.0)

Any ideas?
TIA

mspiegel's picture
Offline
Joined: 07/31/2009
I put a link in the OpenMx

I put a link in the OpenMx repository from the R 2.14 binary to the R 2.13 binary. Unless R 2.14 packages are incompatible with 2.13 packages (which they tend to do all the time), you should be good to go.

rgore's picture
Offline
Joined: 01/27/2011
Using R 2.11, 2.12 or 2.13 should work

Hi David,
Currently we don't have OpenMx to work with R 2.14. It looks like if just hit production yesterday. However, R is currently set up to work with 2.11, 2.12, and 2.13. If download any of those from the R project website OpenMx should run just find. In the mean time, I'll take a look into what we would need to do to get OpenMx set up with 2.14.

Ross

DavidCross's picture
Offline
Joined: 06/27/2011
Thanks for your timely

Thanks for your timely replies! My understanding is that I need R 2.14 to run on OS X Lion. So I think I will wait until you get OpenMx set up with R 2.14.

TIA and Cheers!

rgore's picture
Offline
Joined: 01/27/2011
It should work now.

Hi David,
It appears there is nothing in R 2.14 that breaks OpenMx. As Michael said, now if you type: source('http://openmx.psyc.virginia.edu/getOpenMx.R') in R OpenMx should work for you.

Ross

DavidCross's picture
Offline
Joined: 06/27/2011
OK, I know I am forgetting

OK, I know I am forgetting something (I worked this out once with jags, I think), but I am stuck again:

> library(OpenMx)
Error in dyn.load(file, DLLpath = DLLpath, ...) :
unable to load shared object '/Library/Frameworks/R.framework/Versions/2.14/Resources/library/OpenMx/libs/x86_64/OpenMx.so':
dlopen(/Library/Frameworks/R.framework/Versions/2.14/Resources/library/OpenMx/libs/x86_64/OpenMx.so, 6): Library not loaded: /usr/local//lib/libmpi.0.dylib
Referenced from: /Library/Frameworks/R.framework/Versions/2.14/Resources/library/OpenMx/libs/x86_64/OpenMx.so
Reason: image not found
Error: package/namespace load failed for ‘OpenMx’

Thoughts?

mspiegel's picture
Offline
Joined: 07/31/2009
OK I rebuilt the OpenMx

OK I rebuilt the OpenMx library without MPI. Try re-running the installation script and see if it's fixed.

DavidCross's picture
Offline
Joined: 06/27/2011
That seems to have done it

That seems to have done it ... thanks so much!

DavidCross's picture
Offline
Joined: 06/27/2011
>

> source('http://openmx.psyc.virginia.edu/getOpenMx.R')
trying URL 'http://openmx.psyc.virginia.edu/packages/bin/macosx/leopard/contrib/2.14/OpenMx_1.1.2-1818.tgz'
Content type 'application/x-gzip' length 2262015 bytes (2.2 Mb)
opened URL
==================================================
downloaded 2.2 Mb

The downloaded packages are in
/var/folders/73/jhrbyk5d5mjg2sg0qjsj6z2m0000gn/T//RtmpWJKRJD/downloaded_packages
>

Can you see me smile?

Thanks!