Installation problem on red-hat 64 bit system

4 replies [Last post]
Rachel's picture
Offline
Joined: 02/08/2012

Hi,

I am trying to install OpenMx on a linux red-hat 64 bit system, but I get an error message (see summary below and full output in attached file). I have tried this under R version 2.12.2 and also the latest R version R 2.14.2.
The same error message occurs when installing from the source.
Can you help?

Thanks in advance,
Rachel

> source('http://openmx.psyc.virginia.edu/getOpenMx.R')
trying URL 'http://openmx.psyc.virginia.edu/packages/src/contrib/OpenMx_1.2.0-1926.tar.gz'
Content type 'application/x-gzip' length 7212786 bytes (6.9 Mb)
opened URL
==================================================
downloaded 6.9 Mb

* installing *source* package ‘OpenMx’ ...
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for gcc option to support OpenMP... unsupported
checking whether gcc is installed... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking if gcc accepts -dumpversion option... yes
checking gcc version... 3.4.6
checking for gawk... gawk
checking for inst/npsol/linux/x86/gcc3.4/libnpsol.a... yes
configure: creating ./config.status
config.status: creating src/Makevars
config.status: executing src/omxSymbolTable.h commands
config.status: executing src/omxSymbolTable.c commands
** libs
gcc -std=gnu99 -I/mnt/axonraid/rbrouwer/OpenMx/R-2.14.1/include -I/usr/local/include -Wall -fpic -I/usr/local/Cluster-Apps/netcdf/gcc/64/3.6.0/include -c merge.c -o merge.o
gcc -std=gnu99 -I/mnt/axonraid/rbrouwer/OpenMx/R-2.14.1/include -I/usr/local/include -Wall -fpic -I/usr/local/Cluster-Apps/netcdf/gcc/64/3.6.0/include -c npsolWrap.c -o npsolWrap.o
In file included from omxAlgebra.h:42,
from omxMatrix.h:44,
from omxState.h:64,
from npsolWrap.h:20,
from npsolWrap.c:24:
omxSymbolTable.h:77:7: warning: no newline at end of file

>> many similar warnings as above
....
>> many similar error messages as below

sadmvn.f:1142:
E = BVN(A(:,TID),B(:,TID),INFI(:,TID),COV(2,TID)/D)
1 2
Too few elements (1 missing) as of (2) for array reference at (1)
sadmvn.f:1142:
E = BVN(A(:,TID),B(:,TID),INFI(:,TID),COV(2,TID)/D)
1 2
Invalid token at (2) in expression or subexpression at (1)
sadmvn.f:1142:
E = BVN(A(:,TID),B(:,TID),INFI(:,TID),COV(2,TID)/D)
1 2
Null element at (1) for array reference at (2)
sadmvn.f:1142:
E = BVN(A(:,TID),B(:,TID),INFI(:,TID),COV(2,TID)/D)
1 2
Too few elements (1 missing) as of (2) for array reference at (1)
sadmvn.f:1142:
E = BVN(A(:,TID),B(:,TID),INFI(:,TID),COV(2,TID)/D)
1 2
Invalid token at (2) in expression or subexpression at (1)
sadmvn.f:1134: confused by earlier errors, bailing out
make: *** [sadmvn.o] Error 1
ERROR: compilation failed for package ‘OpenMx’
* removing ‘/mnt/axonraid/rbrouwer/OpenMx/R-2.14.1/library/OpenMx’

The downloaded packages are in
‘/tmp/RtmpCPnLTR/downloaded_packages’
Updating HTML index of packages in '.Library'
Making packages.html ... done
Warning message:
In install.packages(pkgs = c("OpenMx"), repos = repos) :
installation of package ‘OpenMx’ had non-zero exit status

AttachmentSize
OpenMx_installation_error.txt17.17 KB
Rachel's picture
Offline
Joined: 02/08/2012
Thanks

Thanks for the suggestions!

As I do not have root authority on our system, I'll try to get the system administrator to install a newer version of gcc and I'll get back to you,
thanks again!
Rachel

mspiegel's picture
Offline
Joined: 07/31/2009
More specifically, it looks

More specifically, it looks like when I added thread safety to sadmvn.f, I wrote it in a dialect of Fortran that is unacceptable to some of the older compilers. To be honest, I don't really speak Fortran and I'm currently on vacation so I won't be able to debug the problem for a week or so. If the host machine has a module system ("module avail") you might be able to load a more recent version of gcc/gfortran. An alternative is to install OpenMx 1.1 (http://openmx.psyc.virginia.edu/packages/src/contrib/OpenMx_1.1.2-1818.tgz).

rgore's picture
Offline
Joined: 01/27/2011
Your version of gcc needs to be updated

Hi Rachel,
After closer inspection, the problem appears to be with the version of gcc you are using (3.4.6). Please upgrade it to at least 4.2.x. I just built OpenMx successfully on Ubuntu using 4.2.1 and 4.5.2. The parallelization in OpenMx 1.2 takes advantage support of several features (namely OpenMP) in more recent versions of gcc.

rgore's picture
Offline
Joined: 01/27/2011
We're looking at it

Hi Rachel,
It makes sense that you are seeing the same errors on a source installation. The binary for Linux platforms for OpenMx reverts to a 'source' installation. We'll take a look at it and see if we can find what is going awry.

Ross