Installation problem on Mac OS X 10.6.8 (Snow Leopard) and R 2.14.1

2 replies [Last post]
robertfeldt's picture
Offline
Joined: 02/21/2012

Latest versions and updates for OS, R and R Studio:

OS: Mac OS X 10.6.8
R: 2.14.1
RStudio: 0.95.261

When trying to run the install command: source('http://openmx.psyc.virginia.edu/getOpenMx.R')

from the R prompt nothing happens after it loads the tcltk interface:

> source('http://openmx.psyc.virginia.edu/getOpenMx.R')
Loading required package: tcltk
Loading Tcl/Tk interface ...

and when running the install command from the R prompt in RStudio I get a tcltk interface but when I clock the "OK" button under the choice of sequential/multicore choice buttons nothing happens.

I would appreciate any help or prior experience with this issue, thanks.

robertfeldt's picture
Offline
Joined: 02/21/2012
Ok, I found the following

Ok, I found the following solution to install OpenMX without the tcltk panel of the install script:

repos <- c('http://openmx.psyc.virginia.edu/packages/')
install.packages(pkgs=c('OpenMx'), repos=repos)

Might help others with similar problems. I run some of the examples in the Quick-start and things seem to work.

mspiegel's picture
Offline
Joined: 07/31/2009
Thanks for posting the issue

Thanks for posting the issue to the forums. You've found the workaround, I would use it in the interval. This appears to be a Rstudio issue, it looks like you're in good company: http://support.rstudio.org/help/discussions/questions/62-tcltk-in-mac-x11.