Conflict between subversion 1.6 and 1.7

6 replies [Last post]
brandmaier's picture
Offline
Joined: 02/04/2010

I cannot compile OpenMx from SVN.

The repository seems to be running on subversion 1.6 while I am running subversion 1.7. This makes the following version extraction command from the makefile fail:
svnversion -c | sed -e 's/[MS]//g' -e 's/^[[:digit:]]*://'
with the error:
svn: E155036: Working copy '/workspace/OpenMx/trunk' is too old (format 10, created by Subversion 1.6)

I could not found a workaround other than downgrading my subversion to 1.6. Have you encountered this?

brandmaier's picture
Offline
Joined: 02/04/2010
I did. This leads me to the

I did "svn upgrade" and "svn cleanup". This leads me to the behavior that tbrick described earlier in this post.

tbrick's picture
Offline
Joined: 07/31/2009
Workaround for a different error

I'm actually getting a different error from the same command. I'm using svn 1.7.4(r1295709) on Mac OS X 10.7.3.

The command tells me:
svn: E200030: sqlite: callback requested query abort
svn: E200030: sqlite: callback requested query abort

(yes, twice)
and then the compile fails with

Warning: invalid package ‘OpenMx_999.0.0-.tar.gz’
Error: ERROR: no packages specified
make: *** [install] Error 1

because $(BUILDNO) in the Makefile wasn't populated right.
svn upgrade didn't fix it.

A workaround is to manually edit the last line of DESCRIPTION to add the subversion checkout number. I had just checked out r2012, so I changed the line from
Version: 999.0.0-
to
Version: 999.0.0-2012
You could use any number, of course, but then don't trust the version number OpenMx thinks it is.

Might work for your error, too.

mspiegel's picture
Offline
Joined: 07/31/2009
The internet says try "svn

The internet says try "svn cleanup": https://trac.macports.org/ticket/33751

mspiegel's picture
Offline
Joined: 07/31/2009
Try running "svn upgrade" on

Try running "svn upgrade" on your working copy and see if that fixes the problem.

brandmaier's picture
Offline
Joined: 02/04/2010
Can't upgrade

With "svn upgrade" I receive:

svn: E155019: Can't upgrade '/workspace/OpenMx/trunk' as it is not a pre-1.7 working copy root, the root is '/workspace/OpenMx'

I am running svn, Version 1.7.2 (r1207936) on OSX 10.7.3.

Tim's workaround solves the problem. Can we integrate this into the Makefile somehow, e.g. by setting a default version number "0" and issue a warning during the build process?

mspiegel's picture
Offline
Joined: 07/31/2009
Run "svn upgrade" in the

Run "svn upgrade" in the directory '/workspace/OpenMx'