Error in runHelper: "Requested improper value (#, #) from (#, #) matrix".

2 replies [Last post]
HAMED's picture
Offline
Joined: 06/15/2012

Hello,

I'm using metaSEM package developed using OpenMx for conducting meta-analytical structural equation modeling (http://courses.nus.edu.sg/course/psycwlm/Internet/). When applying the mxModel (through tssem1RE function in metaSEM) to my data, I receive a message about an error in runHelper saying that "Requested improper value (5, 41) from (4, 702) matrix" and the function is terminated! I have attached a snapshot of the error message.

Can anyone help me to resolve this error and what can be the possible cause of this error? Is it a known error in OpenMx? I'm new to OpenMx and do not have much knowledge of it!

I'm using R version 2.15.0 and OpenMx version 1.2.4 for Windows.

Any help would be really appreciated,

Thank you,
/Hamed

AttachmentSize
Error Message Snapshot.JPG64.62 KB
Mike Cheung's picture
Offline
Joined: 10/08/2009
Hi Hamed, Since most OpenMx

Hi Hamed,

Since most OpenMx users do not use the metaSEM package, I will try to address them privately.

Mike

tbrick's picture
Offline
Joined: 07/31/2009
If this turns out to be an issue with OpenMx

If this turns out to be an issue with OpenMx, or if we can help you out with the way you interface with OpenMx, please let us know how we can help. We're always looking for ways to help people build add-ons and extensions to OpenMx.

Also, metaSEM looks like a really cool package. Great work!