Fail to Install on R 3.0 on Windows 7

7 replies [Last post]
fnielsen's picture
Offline
Joined: 04/16/2013

I just upgraded to R 3.0 on my Windows 7 PC. I am now trying to reinstall OpenMx. I get the following error message:

> source('http://openmx.psyc.virginia.edu/getOpenMx.R')
Warning: unable to access index for repository http://openmx.psyc.virginia.edu/packages/bin/windows/contrib/3.0

package ‘OpenMx’ is available as a source package but not as a binary

Warning message:
package ‘OpenMx’ is not available (for R version 3.0.0)

Any suggestion on what to do appreciated!

neale's picture
Offline
Joined: 07/31/2009
R 3.0 Not yet supported

Unfortunately, R 3.0 completely broke OpenMx. We are working on a fix. If you can downgrade again to 2.15 (I am not sure if Windows supports multiple versions - if so also install 2.15) you should be ok.

jpritikin's picture
Offline
Joined: 05/23/2012
R 3.0

FYI, OpenMx + R 3.0 works fine on Linux. The breakage is confined to Windows and possibly MacOS.

tbrick's picture
Offline
Joined: 07/31/2009
3.0.0 build

The error given above is because it's looking for a binary install and we haven't built a 3.0.0 binary (so on Linux it works because Linux always builds from source).

As a workaround, if you've got the appropriate tools to build a package from source (Rtools, on a windows machine), you can run:

repos <- c('http://openmx.psyc.virginia.edu/packages/')
install.packages(pkgs=c('OpenMx'), repos=repos, type="source")

And it should install. See http://openmx.psyc.virginia.edu/wiki/howto-build-openmx-source-repository for more details.

Please note that OpenMx on R 3.0.0 has NOT been stringently tested yet (that is, as of April 17, 2013), and we can't guarantee that there aren't ugly bugs in it. We do welcome you to try it and report any errors or problems you encounter, or to just wait for a short while until we roll out a tested 3.0 binary.

tbrick's picture
Offline
Joined: 07/31/2009
I should also add:

I should also add:

I successfully installed from source using this method on a 64-bit Intel Mac running Mac OS 10.6 and R 3.0.0.

There were two problems that I did see when running the test suite in this build:
1) I got several new warnings.
2) Several tests (BivariateSaturated* and bivCorM.R) returned errors because two parameter values were switched. On closer inspection, this appears to be because mvrnorm returned columns of data that were in a different order (also sign-flipped, oddly) than on my usual build. So the variances of X and Y were computed perfectly, but listed in the wrong place because the data columns were interchanged.

Neither of these seems indicative to me of a dangerous computational bug, but of course there's more testing still needed.

neale's picture
Offline
Joined: 07/31/2009
That's cool!

Were there any additional hoops through which you had to jump? Just Xcode and its command-line tools install? Or other fortran/openmp library shenanigans? I got totally stuck trying to build from source under R 2.15.3

tbrick's picture
Offline
Joined: 07/31/2009
XCode Tools + Fortran (+ OpenMP?)

I set this machine up a while back following the HOWTO directions--that covers fortran and the XCode command line tools.

This machine also has OpenMP installed. I don't think you NEED OpenMP to install from source, but one of the more R-savvy folks would know better.

If it doesn't work, you can get OpenMP from http://hpc.sourceforge.net/. Download it and then run this line from the download directory:

sudo tar -xvf gcc-lion.tar -C /

Alternately, if you have fortran but don't want to bother with the OpenMP, there's the single-threaded version of OpenMx. To install the single-threaded version from source, the R commands in my last post change to these:

repos <- c('http://openmx.psyc.virginia.edu/sequential/')
install.packages(pkgs=c('OpenMx'), repos=repos, type="source", configure.args=c('--disable-openmp'))

Note the change from "/packages/" to "/sequential/" and the added configure.args argument.

fnielsen's picture
Offline
Joined: 04/16/2013
Thanks for the Advice!

Y'all:

Thanks for the prompt advice. I'll probably try to install R2.15 concurrently and wait for the 3.0 Windows binary to be ready.