OpenMx Refuses to Compute Confidence Intervals Using Ubuntu and Windows - But Not Mac

1 reply [Last post]
rabil's picture
Offline
Joined: 01/14/2010

I adapted OpenMx ordinal threshold model example code to estimate a model with 5 raters using a 5-point ordinal scale. (The code uses threshold deviations.) The model converges (after some tweaking of starting values) with no errors and no warning messages - this is on a computer running Ubuntu 13.04 and the latest version of OpenMx. The same model was estimated using MPlus - both yield very similar factor loading estimates and threshold estimates (although MPlus used weighted least squares - ML wouldn't work). All attempts at getting OpenMx to produce confidence intervals fail - lower and upper bounds are always NA - whether for factor loadings or thresholds. (Standard errors are shown for every parameter.)

I tried running this on a computer running Ubuntu 12.10 and another running 12.04. They produce the same parameter estimates but no confidence intervals. (Using the same starting values, however, the show code red.) I also tried running this under Windows 7 - nearly identical parameter estimates but no confidence intervals.

Finally, a colleague ran the same model on his Mac - it produced nearly identical parameter estimates AND confidence intervals (still code red).

I've run a lot of models with OpenMx using Ubuntu and had no problems getting what seem like reasonable intervals. Occasionally I've had problems with some upper and some lower bounds (typically equal to the parameter estimate).

Has anyone else run into this problem?

mhunter's picture
Offline
Joined: 07/31/2009
I've occasionally run into

I've occasionally run into differences in parameter estimates across platforms, and accompanying differences in mxStatus (e.g. none vs red). In general, machines and platforms have slight differences in computational errors and their accumulation. Usually it isn't a problem because the likelihood space is fairly smooth and convex (bowl-shaped) but with difficult optimizations or unstable problems, it certainly is possible that small differences compound.

That being said, I haven't personally seen this with confidence intervals before. Has anyone else seen platform differences in confidence intervals?