OpenMX will not install on Windows 7 R2.15

1 reply [Last post]
placidia's picture
Offline
Joined: 06/15/2013

I installed R 32 bit -- I was already running R 64 bit on Windows 7. I launched R and did:

> source('http://openmx.psyc.virginia.edu/getOpenMx.R')
Installing package(s) into ‘C:/Users/Placidia/Documents/R/win-library/2.15’
(as ‘lib’ is unspecified)
trying URL 'http://openmx.psyc.virginia.edu/packages/bin/windows/contrib/2.15/OpenMx_1.3.2-2301.zip'
Content type 'application/zip' length 2367042 bytes (2.3 Mb)
opened URL
downloaded 2.3 Mb

package ‘OpenMx’ successfully unpacked and MD5 sums checked

The downloaded binary packages are in
C:\Users\Placidia\AppData\Local\Temp\RtmpEbJ13Q\downloaded_packages
> require(OpenMX)
Loading required package: OpenMX
Warning message:
In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called ‘OpenMX’

It dumped the zip file in a temporary directory. I navigated to that directory and extracted the files. I now have OpenMX in my douments folder, but R can't see it.

Note: When I installed R 32 bit, I unclicked the check box about noting the version in the registry. I don't know if that matters, but I did not want to mess up my R 64 bit installation.

Thanks in advance.

tbrick's picture
Offline
Joined: 07/31/2009
Possibly just capitalization

Howdy.

It's possible that this is just a capitalization problem--R is case sensitive, and OpenMx is spelled with a capital O and capital M, but everything else lowercase.

You shouldn't have to unzip the package file; that's just there for R to use. If you haven't moved any of the files from where they were, try the library command again with the X lowercase.

library(OpenMx)

If that still doesn't work, we've got a few more things we can try.