Mx 1.x

8 replies [Last post]
tbates's picture
Offline
Joined: 07/31/2009

topic for discussing Mx 1.x scripts

Running the script "models/passing/univACE.mx"

I get the following error suggesting that "select if" is referring to a variable name not in the labels list... which is odd, as it clearly is. Any clues?
t

The following MX script lines were read for group 2
TITLE G2: MZ DATA
Note: Opening #include file 1 ozbmi.dat
DATA NINPUT=12
RECTANGULAR FILE=OZBMI.REC
Rectangular continuous data read initiated
NOTE: Rectangular file contained 3808 records with data
that contained a total of 44853 observations
LABELS FAM AGE ZYG PART WT1 WT2 HT1 HT2 HTWT1 HTWT2 BMI1 BMI2
Note: Closing #include file 1
SELECT IF ZYG=1
We have a problem whose error code is 204
and which I ran across at line number 34
of your input script
SELECT IF ZYG=1
~~~
I can't find the Select If variable in the variable label list' Please check spelling carefully
Problem occurred in group # 2

ifti_ch2002's picture
Offline
Joined: 02/25/2011
Hi all, I dont know exactly

Hi all, I dont know exactly that this is an appropriate forum for my question. Actually i could not find any discussion forum on MX Software page. Thats why i am posting here on Open Mx. I have tried my data to analyze on MX but i receive an error "Your observed covariance matrix is not positive-definite. Check that you are reading it in the correct format". I also tried it on open Mx but it was crashed. I also read the manual, and according to manual there is a problem in the starting values by using lsml. But i could not find any direct function of lsml on Mx. Please let me know about the solution.
Thanks in advance.

Iftikhar Ahmad

tbrick's picture
Offline
Joined: 07/31/2009
If you're getting an error

If you're getting an error about the observed covariance matrix, the problem is not likely to be in your starting values.

The odds are good that the problem is exactly what it says--that is, the covariance matrix that is being submitted as data is incorrect. You can check this in a couple of ways. I would probably check it by first loading the covariance matrix into R and examining it. The diagonal should be strictly positive values, the matrix should be symmetric, there should be no duplicate rows and no rows of all zeros. If you run eigvals <- eigen(myCov, only.values=TRUE), where myCov is the name of your covariance matrix, then eigvals$values should be a list of positive values, one for each row of your covariance matrix.

If your covariance matrix doesn't pass these tests, something is wrong further up the line. Where are you getting your covariance matrix from? How is it being calculated?

If your observed covariance matrix does pass these tests, but you're still getting the error, I'm not sure what the problem is. Are you getting the same error from OpenMx as you were from classic MX?

davidhj6's picture
Offline
Joined: 05/26/2011
Awesome

I have problem with the covariance matrix but now its solved . it needs a bit understanding of the pivot table also. Did u ever study blacksholes model?

Steve's picture
Offline
Joined: 07/30/2009
Could you post the script

Could you post the script that crashed OpenMx? It is hard to tell what the problem is without a script.

Sanja's picture
Offline
Joined: 12/07/2009
HI, I have a question about

HI, I have a question about classic Mx. How do you save the Project Manager file so that it is accessible later? (I can save it but can't open later). Thanks

*PS. I know it is all in the .mxo file as well, but for models with many variables I find it useful to have the results in the Project Manager form

neale's picture
Offline
Joined: 07/31/2009
Hi Sanja Hmmm that is a

Hi Sanja

Hmmm that is a little explored part of functionality of Classic Mx's GUI. If the Mx GUI cannot read it back in itself (I would start with a cleanly started Mx GUI) then please report it to gxie at vcu.edu as a possible bug.

Sanja's picture
Offline
Joined: 12/07/2009
Just reported it, thanks.

Just reported it, thanks. Tried opening with a cleanly started Mx GUI but it did not work.
Sanja

tbates's picture
Offline
Joined: 07/31/2009
so the file as included

so the file as included doesn't run on OS X Mx 1.5

this causes an error

Select if zyg=1

this works

Select if zyg =1

pushed revision