accessing model elements

4 replies [Last post]
Dorothy Bishop's picture
Offline
Joined: 02/04/2010

The OpenMx style guide says:
The first useful trick is entering the string model$ in the R interpreter and then pressing the TAB key. You should see a list of all the named entities contained within the model object

I enterd the prior script to define model, but, alas, when I enter:
model$
and press Tab
absolutely nothing happens.
I have a bog standard PC and am using R via the Gui.

Thought I must be doing something stupid and tried several times but no joy.

Mike Cheung's picture
Offline
Joined: 10/08/2009
It seems that it works in

It seems that it works in Emacs with ESS.

Steve's picture
Offline
Joined: 07/30/2009
It works in the Mac OS-X

It works in the Mac OS-X terminal window. You do need to press tab twice. The first time does nothing. The second tab press brings up the list of possibilities.

It doesn't work in the Mac OS-X R-64 GUI.

How tab completion works is dependent on which console you are using.

I personally work in R using TextMate for the editor and Terminal (with tcsh and emac keys turned on) on Mac OS-X. I like this the best out of all of the combinations I've tried. As they say, YMMV.

mspiegel's picture
Offline
Joined: 07/31/2009
Under Windows 7, in the RGui

Under Windows 7, in the RGui running R 2.10.1 and with mxVersion() reporting 0.2.10-1172, I observe the same behavior as Steve reported in the Mac OS-X terminal.

tbates's picture
Offline
Joined: 07/31/2009
Yes: Not sure where that

Yes: Not sure where that claim came from - I have not seen it as an R behavior either.