Installation problem on RedHat Enterprise 4

2 replies [Last post]
mwaldron's picture
Offline
Joined: 04/19/2010

I'm trying to install OpenMx using R-2.10.1 on RedHat Enterprise 4, and I get the following error in the compile:

gcc -std=gnu99 -shared -L/usr/local/lib64 -o OpenMx.so npsolWrap.o omxAlgebra.o omxAlgebraFunctions.o omxAlgebraObjective.o omxData.o omxFIMLObjective.o omxMLObjective.o omxMatrix.o omxObjective.o omxObjectiveTable.o omxRAMObjective.o omxRObjective.o omxRowObjective.o omxState.o omxSymbolTable.o sadmvn.o -lgfortran -lm -L/afs/.isis/pkg/r-2.10.1/lib/R/lib -lRblas -L/afs/.isis/pkg/r-2.10.1/lib/R/lib -lRlapack -lnpsol -L../inst/npsol/linux/x86/gcc3.4 -lgfortran -lm -L/afs/.isis/pkg/r-2.10.1/lib/R/lib -lR
/usr/bin/ld: cannot find -lgfortran
collect2: ld returned 1 exit status
make: *** [OpenMx.so] Error 1
ERROR: compilation failed for package 'OpenMx'

I noticed the -L/usr/local/lib64 argument, I don't have this directory on this system, it's 32-bit, I suspect this is the problem. The libgfortran files are in /usr/lib.

I successfully installed this on a RedHat Enterprise 5 system which is 64-bit.

I'm using source('http://openmx.psyc.virginia.edu/getOpenMx.R') to do the install. Any assistance would be appreciated.

Thanks,
Mike

mspiegel's picture
Offline
Joined: 07/31/2009
Whoops. Skimmed your post

Whoops. Skimmed your post before having breakfast this morning. OK, so you have located the gfortran libraries on your system but they are not being included in the -L locations. I would add CFLAGS=-L/usr/lib to a custom make variables file. See: http://cran.r-project.org/doc/manuals/R-admin.html#Customizing-package-c....

mwaldron's picture
Offline
Joined: 04/19/2010
Ah, that was the problem

Ah, that was the problem (Indirectly). I forgot that I put a $HOME/.R/Makeconf in place that was written for a 64-bit installation. As soon as I moved that out of the way, OpenMx installed on the 32-bit installation.

Thanks.