class "MxModel" does not extend that class

3 replies [Last post]
mpib-admin's picture
Offline
Joined: 05/10/2010

Hello everybody,

we are very new to R and OpenMx and are trying to get it running on Debian GNU/Linux Lenny. We downloaded and (successfully) installed the openmx-package. But when we try to run our Script we get the following error:

##
Error in initialize(value, ...) :
cannot use object of class "character" in new(): class "MxModel" does not extend that class
Calls: DAF_simulation ... mxModel -> firstArgument -> new -> initialize -> initialize
Execution halted
##

On Windows the same script with the same OpenMx-Version runs just fine and this is what we don't understand, because it seems like a structural error in the MxModel class.

Our R version is (due to Debian lenny) somewhat old : R version 2.7.1 (2008-06-23)
Do you know what might be the problem here?

regards,
Michael

Steve's picture
Offline
Joined: 07/30/2009
I think you've found the

I think you've found the problem. We have only tested on R version 2.9 and later. From your description, I suspect that part of the S4 class structure we use was not yet implemented on R version 2.7.1. It shouldn't be too difficult to update your R installation.

mspiegel's picture
Offline
Joined: 07/31/2009
Compiling R from source is an

Compiling R from source is an option on linux boxes. I can't remember how easy it is to install a Debian "unstable" package on a box running the "stable" release.

mpib-admin's picture
Offline
Joined: 05/10/2010
Compiling from sources and

Compiling from sources and mixed-release setups was something we tried to avoid for stability reasons.
Nevertheless after trying R from the "testing" archive we got it working. Thanks for your hints!