Error in registerS3method

1 reply [Last post]
Hermine's picture
Offline
Joined: 07/31/2009

After sourcing the latest version of OpenMx on a Windows XP machine running R 2.9.2, we get the following error upon 'require(OpenMx):

require(OpenMx)
Loading required package: OpenMx
Error in registerS3method(Info[i, 1], Info[i, 2], Info[i, 3], env) :
no slot of name "methods" for this object of class "derivedDefaultMethod"
In addition: Warning message:
package 'OpenMx' was built under R version 2.11.0

Any suggestions on how to fix this?

Thanks,
Roseann & Hermine.

mspiegel's picture
Offline
Joined: 07/31/2009
We stopped compiling OpenMx

We stopped compiling OpenMx for R 2.9.2. See (http://openmx.psyc.virginia.edu/thread/622). We now compile for R 2.11.x and 2.12.x. R 2.9.2 was released in August, 2009. It is possible to upgrade to a newer version on that machine?